Application Install not functioning

Description

Phone #87 was set up with mCerebrum version 2.0 for testing. After I clicked "Leave Study" to return phone to "Default User," (to get ready for use for real study participants) the page shows 4 applications that need to be installed. When I click "Install All," the phone begins to download the "StudyDataCollection" App, but then gets stuck in a loop of saying this app is installed and then starting the download process over again. Nothing will install. After exiting the mCerebrum app and re-entering, the app shows the same 4 applications that need to be installed, but also 3 applications that need to be updated. When I click "Check Updates" and "Yes" under "Do You Want to Update," the mCerebrum app returns to the home page and will not perform any updates. If I click on individual apps to update them individually, the begin to download and then say "App not installed." I was able to individually install AutoSense Chest Sensor BLE, Beacon, and Alertness Sensing Framework, but cannot install StudyDataCollection and cannot update WristSensor, Storage, or mCerebrum. However, on the home page it says "Installation Successful" and has a green check mark. I don't know if this phone will work properly.

Environment

None

Activity

Show:
University Utah
April 17, 2019, 7:48 PM

I think we resolved this/realized our mistake. We were not actually logged in to our study. Once we entered those username/password combinations we were able to install/update the applications we needed.

Shahin Samiei
April 17, 2019, 8:10 PM

Thanks : This is correct. Logging in first is required to establish the suite of applications required for the OnTrack study configuration.
Thanks as always for reaching out,
-Shahin

Done

Assignee

Shahin Samiei

Reporter

University Utah

Priority

Highest